Genie's Tech Blog

Where knowledge has no dimensions

MPLS TE: Auto-Tunnel Mesh Groups

Hello Friends

Today, I am going to discuss about one of the interesting features on MPLS TE which is the Auto-Tunnel feature which gives us the capability to create TE tunnels automatically based on the destination list. The Auto-Tunnel feature provides automatic creation of one-hop primary TE tunnels (Auto-Tunnel Primary), and both nhop and nnhop FRR backup TE tunnels (Auto-Tunnel Backup).  Auto-Tunnel Primary and Backup can be enabled separately via CLI configuration. The Auto-Tunnel Primary feature, once enabled, causes the router to dynamically create one-hop tunnels to directly connected neighbors on all interfaces that have been configured with "mpls traffic-eng tunnels". The Auto-Tunnel Backup feature, once enabled, causes the router to dynamically create nhop and nnhop FRR backup tunnels, and assign those backup tunnels to protected interfaces where no statically configured backup tunnel is already available.

Along with the Auto-Tunnels, we will also be discussing on Auto-Mesh Tunnels. The Auto-Mesh feature, once enabled , will cause the router to dynamically create a mesh of TE tunnels to all the PE routers configured for the same mesh-group, or who’s TE router-id is contained in a configured Access List (ACL). For the Auto-Mesh feature, it is required to configure one or more auto-template interfaces, which contains all the mesh tunnel interface configurations that will be used for creating the dynamic auto-mesh TE tunnel.  The only exception is the tunnel destination config, which will be obtained from the mesh-group or access-list, depending on the auto-template configuration. Please remember that you cannot configure Inter-Area tunnels for Autotunnel Mesh groups.

There are basically two types of Mesh-Groups:

a) Full: Where each PE router has a tunnel to each of the other PE routers.

b) Partial: Where some of the PE's are not connected to each other by tunnels.

Auto-Tunnel Mesh groups can be configured in simple steps:

1. Enable Auto-Tunnel mesh groups globally using the cli "mpls traffic-eng auto-tunnel mesh".

2. Create an access-list to the desitnation

3. Create a Template for the Auto-Tunnels

Lets now consider the below topology to see how this behaves:

 

I am using all the 4 routers as the 7600 routers with 15.0(1)S5 IOS version on it. Lets now have a look at the configuration of all the routers:

Common Config on All routers:
======================
no mpls ip propagate-ttl forwarded
mpls ldp label
 allocate global host-routes
mpls traffic-eng tunnels
mpls traffic-eng logging lsp path-errors
mpls traffic-eng logging lsp reservation-errors
mpls traffic-eng logging lsp setups
mpls traffic-eng logging lsp teardowns
mpls traffic-eng logging tunnel path change
mpls traffic-eng auto-tunnel backup
mpls traffic-eng auto-tunnel backup tunnel-num min 5000 max 6000
mpls traffic-eng auto-tunnel mesh
mpls traffic-eng auto-tunnel mesh tunnel-num min 1000 max 2000
mpls traffic-eng reoptimize timers frequency 1800
mpls label protocol ldp
clns routing
no mls flow ip
no mls flow ipv6
mls rate-limit multicast ipv4 fib-miss 1000 10
mls rate-limit multicast ipv4 connected 1000 10
mls rate-limit multicast ipv4 igmp 100 10
mls rate-limit multicast ipv4 ip-options 100 10
mls rate-limit unicast ip icmp redirect 1000 10
mls rate-limit all ttl-failure 100 10
mls rate-limit all mtu-failure 100 10
no mls acl tcam share-global
mls cef error action freeze
!
ip tcp path-mtu-discovery
!
ip rsvp signalling refresh reduction
ip rsvp signalling hello
ip rsvp signalling hello bfd
!
access-list 25 permit 10.0.0.0 0.255.255.255
!
interface Auto-Template1
 ip unnumbered Loopback0
 mpls ip
 mpls mtu 17868
 tunnel mode mpls traffic-eng
 tunnel destination access-list 25
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 4 4
 tunnel mpls traffic-eng path-option 10 dynamic
 tunnel mpls traffic-eng fast-reroute
!
mpls ldp router-id lo0 force
!

Config on 7600-PE1:
===============
interface Loopback0
 ip address 10.1.0.1 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet1/1
 mtu 4470
 ip address 12.12.12.1 255.255.255.252
 ip router isis 
 mpls traffic-eng tunnels
 bfd interval 250 min_rx 250 multiplier 3
 isis circuit-type level-2-only
 isis network point-to-point 
 isis metric 15 level-2
 isis hello-interval 4
 isis csnp-interval 10
 hold-queue 4096 in
 hold-queue 4096 out
 ip rsvp bandwidth 1000000
 ip rsvp signalling hello bfd
!
interface GigabitEthernet1/3
 mtu 4470
 ip address 13.13.13.1 255.255.255.252
 ip router isis 
 mpls traffic-eng tunnels
 bfd interval 250 min_rx 250 multiplier 3
 isis circuit-type level-2-only
 isis network point-to-point 
 isis metric 15 level-2
 isis hello-interval 4
 hold-queue 4096 in
 hold-queue 4096 out
 ip rsvp bandwidth 1000000
 ip rsvp signalling hello bfd
!
router isis
 net 49.0100.1111.1111.00
 is-type level-2-only
 metric-style wide
 set-overload-bit on-startup wait-for-bgp
 spf-interval 10 100 1000
 prc-interval 10 100 1000
 no hello padding
 log-adjacency-changes
 distance 80 ip
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 mpls traffic-eng multicast-intact
!

Config on 7600-P1:
=============
interface Loopback0
 ip address 10.2.0.1 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!         
interface GigabitEthernet1/1
 mtu 4470 
 ip address 13.13.13.2 255.255.255.252
 ip router isis 
 mpls traffic-eng tunnels
 bfd interval 250 min_rx 250 multiplier 3
 isis circuit-type level-2-only
 isis network point-to-point 
 isis metric 15 level-2
 isis hello-interval 4
 hold-queue 4096 in
 hold-queue 4096 out
 ip rsvp bandwidth 1000000
 ip rsvp signalling hello bfd
!         
interface POS3/0/0
 ip address 24.24.24.1 255.255.255.252
 ip router isis 
 mpls traffic-eng tunnels
 bfd interval 250 min_rx 250 multiplier 3
 isis circuit-type level-2-only
 isis metric 15 level-2
 isis hello-interval 4
 hold-queue 4096 in
 hold-queue 4096 out
 ip rsvp bandwidth 1000000
 ip rsvp signalling hello bfd
!         
router isis
 net 49.0100.2222.2222.00
 is-type level-2-only
 metric-style wide
 set-overload-bit on-startup wait-for-bgp
 spf-interval 10 100 1000
 prc-interval 10 100 1000
 no hello padding
 log-adjacency-changes
 distance 80 ip
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 mpls traffic-eng multicast-intact
! 

Config on 7600-P2:
=============
interface Loopback0
 ip address 10.3.0.1 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!  
interface GigabitEthernet4/1
 mtu 4470 
 ip address 34.34.34.1 255.255.255.252
 ip router isis 
 mpls traffic-eng tunnels
 bfd interval 250 min_rx 250 multiplier 3
 isis circuit-type level-2-only
 isis network point-to-point 
 isis metric 15 level-2
 isis hello-interval 4
 hold-queue 4096 in
 hold-queue 4096 out
 ip rsvp bandwidth 1000000
 ip rsvp signalling hello bfd
!
interface GigabitEthernet4/2
 mtu 4470
 ip address 12.12.12.2 255.255.255.252
 ip router isis 
 mpls traffic-eng tunnels
 bfd interval 250 min_rx 250 multiplier 3
 isis circuit-type level-2-only
 isis network point-to-point 
 isis metric 15 level-2
 isis hello-interval 4
 hold-queue 4096 in
 hold-queue 4096 out
 ip rsvp bandwidth 1000000
 ip rsvp signalling hello bfd
!
router isis
 net 49.0100.3333.3333.00
 is-type level-2-only
 metric-style wide
 set-overload-bit on-startup wait-for-bgp
 spf-interval 10 100 1000
 prc-interval 10 100 1000
 no hello padding
 log-adjacency-changes
 distance 80 ip
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 mpls traffic-eng multicast-intact
!

Config on 7600-PE2:
===============
interface Loopback0
 ip address 10.4.0.1 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet2/1
 mtu 4470
 ip address 34.34.34.2 255.255.255.252
 ip router isis 
 mpls traffic-eng tunnels
 bfd interval 250 min_rx 250 multiplier 3
 isis circuit-type level-2-only
 isis network point-to-point 
 isis metric 15 level-2
 isis hello-interval 4
 hold-queue 4096 in
 hold-queue 4096 out
 ip rsvp bandwidth 1000000
 ip rsvp signalling hello bfd
!
interface POS3/0/1
 ip address 24.24.24.2 255.255.255.252
 ip router isis 
 mpls traffic-eng tunnels
 bfd interval 250 min_rx 250 multiplier 3
 isis circuit-type level-2-only
 isis metric 15 level-2
 isis hello-interval 4
 hold-queue 4096 in
 hold-queue 4096 out
 ip rsvp bandwidth 1000000
 ip rsvp signalling hello bfd
!
router isis
 net 49.0100.4444.4444.00
 is-type level-2-only
 metric-style wide
 set-overload-bit on-startup wait-for-bgp
 spf-interval 10 100 1000
 prc-interval 10 100 1000
 no hello padding
 log-adjacency-changes
 distance 80 ip
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 mpls traffic-eng multicast-intact
!

The above configuration will help you bring up the AutoTunnel mesh groups. If you see the see the section of common config for the all the routers, you will notice that we configured, I have enabled mesh groups for TE, then created an access-list to match the destination where I want the tailend of the Tunnels and then configured Auto-Template which is used for autotunnels for this mesh group. Once the router finds the routes matching in the IGP table to the access-list, they start perform the pcalc and run the CSPF for creating one-hop TE Auto-tunnels. Lets now have a look at the show commands to see how tunnels look in the output. Please remember that for every tunnel created, there will be no configuration available.

Outputs on PE1:
===========
7600-PE1#show mpls traffic-eng tunnels 

P2P TUNNELS/LSPs:

Name: 7600-PE1_t1000                      (Tunnel1000) Destination: 10.3.0.1
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 15)

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 4  4   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute announce: enabled  LockDown: disabled Loadshare: 0 [0] bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled


  InLabel  :  -
  OutLabel : GigabitEthernet1/1, implicit-null
  Next Hop : 12.12.12.2
  FRR OutLabel : Tunnel5000, explicit-null 
  RSVP Signalling Info:
       Src 10.1.0.1, Dst 10.3.0.1, Tun_Id 1000, Tun_Instance 3930
    RSVP Path Info:
      My Address: 12.12.12.1   
      Explicit Route: 12.12.12.2 10.3.0.1 
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:  10.3.0.1(0)
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
  History:
    Tunnel:
      Time since created: 6 days, 22 hours, 11 minutes
      Time since path change: 3 days, 11 hours, 14 minutes
      Number of LSP IDs (Tun_Instances) used: 335
    Current LSP: [ID: 3930]
      Uptime: 3 days, 11 hours, 14 minutes
      Selection: reoptimization
    Prior LSP: [ID: 3929]
      ID: path option 10 [3763]
      Removal Trigger: reoptimization completed
      Last Error: RSVP:: Path Error from 10.1.0.1: Notify: Tunnel locally repaired (flags 0)

Name: 7600-PE1_t1001                      (Tunnel1001) Destination: 10.2.0.1
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 15)

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 4  4   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute announce: enabled  LockDown: disabled Loadshare: 0 [0] bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled


  InLabel  :  -
  OutLabel : GigabitEthernet1/3, implicit-null
  Next Hop : 13.13.13.2
  FRR OutLabel : Tunnel5002, explicit-null 
  RSVP Signalling Info:
       Src 10.1.0.1, Dst 10.2.0.1, Tun_Id 1001, Tun_Instance 6435
    RSVP Path Info:
      My Address: 13.13.13.1   
      Explicit Route: 13.13.13.2 10.2.0.1 
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:  10.2.0.1(0)
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
  History:
    Tunnel:
      Time since created: 6 days, 22 hours, 12 minutes
      Time since path change: 6 days, 21 hours, 45 minutes
      Number of LSP IDs (Tun_Instances) used: 334
    Current LSP: [ID: 6435]
      Uptime: 6 days, 21 hours, 45 minutes
      Selection: reoptimization
    Prior LSP: [ID: 6434]
      ID: path option unknown
      Removal Trigger: reoptimization completed

Name: 7600-PE1_t1002                      (Tunnel1002) Destination: 10.4.0.1
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 30)

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 4  4   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute announce: enabled  LockDown: disabled Loadshare: 0 [0] bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled


  InLabel  :  -
  OutLabel : GigabitEthernet1/3, 226
  Next Hop : 13.13.13.2
  FRR OutLabel : Tunnel5003, explicit-null 
  RSVP Signalling Info:
       Src 10.1.0.1, Dst 10.4.0.1, Tun_Id 1002, Tun_Instance 1118
    RSVP Path Info:
      My Address: 13.13.13.1   
      Explicit Route: 13.13.13.2 42.42.42.2 10.4.0.1 
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:  10.2.0.1(226) 10.4.0.1(0)
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
  History:
    Tunnel:
      Time since created: 6 days, 22 hours, 12 minutes
      Time since path change: 3 days, 11 hours, 32 minutes
      Number of LSP IDs (Tun_Instances) used: 334
    Current LSP: [ID: 1118]
      Uptime: 3 days, 11 hours, 32 minutes
      Selection: reoptimization
    Prior LSP: [ID: 952]
      ID: path option 10 [952]
      Removal Trigger: re-route path error
      Last Error: RSVP:: Path Error from 10.1.0.1: Notify: Tunnel locally repaired (flags 0)

Name: 7600-PE1_t1003                      (Tunnel1003) Destination: 10.11.12.2
  Status:
    Admin: up         Oper: down   Path: not valid   Signalling: Down
    path option 10, type dynamic

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 4  4   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute announce: enabled  LockDown: disabled Loadshare: 0 [0] bw-based
    auto-bw: disabled

  History:
    Tunnel:
      Time since created: 4 days, 8 hours, 42 minutes
      Number of LSP IDs (Tun_Instances) used: 7703

Name: 7600-PE1_t5000                      (Tunnel5000) Destination: 10.3.0.1
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 1, type explicit __dynamic_tunnel5000 (Basis for Setup, path weight 45)

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute announce: disabled LockDown: disabled Loadshare: 0 [0] bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: explicit path option 1 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled

  InLabel  :  -
  OutLabel : GigabitEthernet1/3, 22
  Next Hop : 13.13.13.2
  RSVP Signalling Info:
       Src 10.1.0.1, Dst 10.3.0.1, Tun_Id 5000, Tun_Instance 8
    RSVP Path Info:
      My Address: 13.13.13.1   
      Explicit Route: 13.13.13.2 42.42.42.2 34.34.34.1 10.3.0.1 
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
  History:
    Tunnel:
      Time since created: 6 days, 22 hours, 13 minutes
      Time since path change: 6 days, 22 hours, 13 minutes
      Number of LSP IDs (Tun_Instances) used: 8
    Current LSP: [ID: 8]
      Uptime: 6 days, 22 hours, 13 minutes

Name: 7600-PE1_t5002                      (Tunnel5002) Destination: 10.2.0.1
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 1, type explicit __dynamic_tunnel5002 (Basis for Setup, path weight 45)

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute announce: disabled LockDown: disabled Loadshare: 0 [0] bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: explicit path option 1 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled


  InLabel  :  -
  OutLabel : GigabitEthernet1/1, 224
  Next Hop : 12.12.12.2
  RSVP Signalling Info:
       Src 10.1.0.1, Dst 10.2.0.1, Tun_Id 5002, Tun_Instance 172
    RSVP Path Info:
      My Address: 12.12.12.1   
      Explicit Route: 12.12.12.2 34.34.34.2 42.42.42.1 10.2.0.1 
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
  History:
    Tunnel:
      Time since created: 6 days, 21 hours, 46 minutes
      Time since path change: 3 days, 11 hours, 32 minutes
      Number of LSP IDs (Tun_Instances) used: 172
    Current LSP: [ID: 172]
      Uptime: 3 days, 11 hours, 32 minutes
    Prior LSP: [ID: 1]
      ID: path option unknown
      Removal Trigger: path error

Name: 7600-PE1_t5003                      (Tunnel5003) Destination: 10.4.0.1
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 1, type explicit __dynamic_tunnel5003 (Basis for Setup, path weight 30)

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute announce: disabled LockDown: disabled Loadshare: 0 [0] bw-based

    auto-bw: disabled
  Active Path Option Parameters:
    State: explicit path option 1 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled


  InLabel  :  -
  OutLabel : GigabitEthernet1/1, 223
  Next Hop : 12.12.12.2
  RSVP Signalling Info:
       Src 10.1.0.1, Dst 10.4.0.1, Tun_Id 5003, Tun_Instance 5
    RSVP Path Info:
      My Address: 12.12.12.1   
      Explicit Route: 12.12.12.2 34.34.34.2 10.4.0.1 
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
  History:
    Tunnel:
      Time since created: 3 days, 11 hours, 33 minutes
      Time since path change: 3 days, 11 hours, 33 minutes
      Number of LSP IDs (Tun_Instances) used: 5
    Current LSP: [ID: 5]
      Uptime: 3 days, 11 hours, 33 minutes

LSP Tunnel 10.1.0.1 1 is signalled, connection is down

LSP Tunnel 7600-P1_t1000 is signalled, connection is up
  InLabel  : GigabitEthernet1/3, implicit-null
  Prev Hop : 13.13.13.2
  OutLabel :  - 
  RSVP Signalling Info:
       Src 10.2.0.1, Dst 10.1.0.1, Tun_Id 1000, Tun_Instance 1577
    RSVP Path Info:
      My Address: 10.1.0.1   
      Explicit Route:  NONE
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits


LSP Tunnel 7600-P1_t5000 is signalled, connection is up
  InLabel  : GigabitEthernet1/1, implicit-null
  Prev Hop : 12.12.12.2
  OutLabel :  - 
  RSVP Signalling Info:
       Src 10.2.0.1, Dst 10.1.0.1, Tun_Id 5000, Tun_Instance 786
    RSVP Path Info:
      My Address: 10.1.0.1   
      Explicit Route:  NONE
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

LSP Tunnel 7600-P1_t5004 is signalled, connection is up
  InLabel  : GigabitEthernet1/3, 226
  Prev Hop : 13.13.13.2
  OutLabel : GigabitEthernet1/1, implicit-null
  Next Hop : 12.12.12.2
  RSVP Signalling Info:
       Src 10.2.0.1, Dst 10.3.0.1, Tun_Id 5004, Tun_Instance 333
    RSVP Path Info:
      My Address: 12.12.12.1   
      Explicit Route: 12.12.12.2 10.3.0.1 
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

LSP Tunnel 7600-P2_t1000 is signalled, connection is up
  InLabel  : GigabitEthernet1/1, implicit-null
  Prev Hop : 12.12.12.2
  OutLabel :  - 
  RSVP Signalling Info:
       Src 10.3.0.1, Dst 10.1.0.1, Tun_Id 1000, Tun_Instance 8973
    RSVP Path Info:
      My Address: 10.1.0.1   
      Explicit Route:  NONE
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

LSP Tunnel 7600-P2_t5001 is signalled, connection is up
  InLabel  : GigabitEthernet1/3, implicit-null
  Prev Hop : 13.13.13.2
  OutLabel :  - 
  RSVP Signalling Info:
       Src 10.3.0.1, Dst 10.1.0.1, Tun_Id 5001, Tun_Instance 561
    RSVP Path Info:
      My Address: 10.1.0.1   
      Explicit Route:  NONE
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

LSP Tunnel 7600-P2_t5002 is signalled, connection is up
  InLabel  : GigabitEthernet1/1, 225
  Prev Hop : 12.12.12.2
  OutLabel : GigabitEthernet1/3, 228
  Next Hop : 13.13.13.2
  RSVP Signalling Info:
       Src 10.3.0.1, Dst 10.4.0.1, Tun_Id 5002, Tun_Instance 644
    RSVP Path Info:
      My Address: 13.13.13.1   
      Explicit Route: 13.13.13.2 42.42.42.2 10.4.0.1 
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

LSP Tunnel 7600-P2_t5003 is signalled, connection is up
  InLabel  : GigabitEthernet1/1, 224
  Prev Hop : 12.12.12.2
  OutLabel : GigabitEthernet1/3, implicit-null
  Next Hop : 13.13.13.2
  RSVP Signalling Info:
       Src 10.3.0.1, Dst 10.2.0.1, Tun_Id 5003, Tun_Instance 582
    RSVP Path Info:
      My Address: 13.13.13.1   
      Explicit Route: 13.13.13.2 10.2.0.1 
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

LSP Tunnel 7600-PE2_t5000 is signalled, connection is up
  InLabel  : GigabitEthernet1/3, 227
  Prev Hop : 13.13.13.2
  OutLabel : GigabitEthernet1/1, implicit-null
  Next Hop : 12.12.12.2
  RSVP Signalling Info:
       Src 10.4.0.1, Dst 10.3.0.1, Tun_Id 5000, Tun_Instance 587
    RSVP Path Info:
      My Address: 12.12.12.1   
      Explicit Route: 12.12.12.2 10.3.0.1 
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

P2MP TUNNELS:

P2MP SUB-LSPS:

7600-PE1#sh mpls traffic-eng fast-reroute database 
P2P Headend FRR information:
Protected tunnel               In-label Out intf/label   FRR intf/label   Status
---------------------------    -------- --------------   --------------   ------
Tunnel1000                     Tun hd   Gi1/1:implicit-n Tu5000:implicit- Ready 
Tunnel1001                     Tun hd   Gi1/3:implicit-n Tu5002:implicit- Ready 
Tunnel1002                     Tun hd   Gi1/3:226        Tu5003:implicit- Ready 

P2P LSP midpoint frr information:
LSP identifier                 In-label Out intf/label   FRR intf/label   Status
---------------------------    -------- --------------   --------------   ------

P2MP Sub-LSP FRR information:
*Sub-LSP identifier
src_lspid[subid]->dst_tunid    In-label Out intf/label   FRR intf/label   Status
---------------------------    -------- --------------   --------------   ------

* Sub-LSP identifier format: <TunSrc>_<LSP_ID>[SubgroupID]-><TunDst>_<Tun_ID>
  Note: Sub-LSP identifier may be truncated.
  Use 'detail' display for the complete key.
7600-PE1#

7600-PE1#sh mpls traffic-eng fast-reroute database  det
FRR Database Summary:
  Protected interfaces    : 2
  Protected LSPs/Sub-LSPs : 3
  Backup tunnels          : 3
  Active interfaces       : 0

P2P LSPs:

 Tun ID: 1000, LSP ID: 3930, Source: 10.1.0.1
 Destination: 10.3.0.1
  State        : Ready
  InLabel      : Tunnel Head
  OutLabel     : Gi1/1:implicit-null
  FRR OutLabel : Tu5000:implicit-null

 Tun ID: 1001, LSP ID: 6435, Source: 10.1.0.1
 Destination: 10.2.0.1
  State        : Ready
  InLabel      : Tunnel Head
  OutLabel     : Gi1/3:implicit-null
  FRR OutLabel : Tu5002:implicit-null

 Tun ID: 1002, LSP ID: 1118, Source: 10.1.0.1
 Destination: 10.4.0.1
  State        : Ready
  InLabel      : Tunnel Head
  OutLabel     : Gi1/3:226
  FRR OutLabel : Tu5003:implicit-null
          
P2MP Sub-LSPs:

7600-PE1#show adjacency tunnel1000 internal
Protocol Interface                 Address
IP       Tunnel1000                point2point(9)
                                   0 packets, 0 bytes
                                   epoch 0
                                   sourced in sev-epoch 0
                                   empty encap string
                                   P2P-ADJ
                                   Next chain element:
                                    label implicit-null
                                   FRR Primary
                                   <primary:  IP adj out of GigabitEthernet1/1, addr 12.12.12.2>
                                    parent oce 0x5027FA60
                                   L3 mtu 4470
                                   Flags (0x128C6)
                                   Fixup disabled
                                   HWIDB/IDB pointers 0x4781DEA8/0x4781EC74
                                   IP redirect disabled
                                   Switching vector: IPv4 midchain adj oce
                                   Output features: HW Shortcut Installation
                                   Next-hop inferred from 1 reference
                                   MPLS subblock: flags 0x4 
                                      GigabitEthernet1/1 12.12.12.2 label implicit-null
Protocol Interface                 Address
                                      FRR protected by Tunnel5000 label implicit-null
                                      chain pointer 0x5027FA60:  label implicit-null
                                     FRR Primary
                                     <primary:  IP adj out of GigabitEthernet1/1, addr 12.12.12.2>
                                      adj-sb send-slotmask: 0x0 
                                   Adjacency pointer 0x4781B440
                                   Next-hop 10.3.0.1
TAG      Tunnel1000                point2point(4)
                                   0 packets, 0 bytes
                                   epoch 0
                                   sourced in sev-epoch 0
                                   empty encap string
                                   P2P-ADJ
                                   Next chain element:
                                    label implicit-null
                                   FRR Primary
                                   <primary:  TAG adj out of GigabitEthernet1/1, addr 12.12.12.2>
                                    parent oce 0x5027FF40
                                   L3 mtu 4470
                                   Flags (0x128C6)
Protocol Interface                 Address
                                   Fixup disabled
                                   HWIDB/IDB pointers 0x4781DEA8/0x4781EC74
                                   IP redirect disabled
                                   Switching vector: MPLS midchain adjacency oce
                                   Next-hop cannot be inferred
                                   MPLS subblock: flags 0x4 
                                      GigabitEthernet1/1 12.12.12.2 label implicit-null
                                      FRR protected by Tunnel5000 label implicit-null
                                      chain pointer 0x5027FF40:  label implicit-null
                                     FRR Primary
                                     <primary:  TAG adj out of GigabitEthernet1/1, addr 12.12.12.2>
                                      adj-sb send-slotmask: 0x0 

                                   Adjacency platform space:
                                     TE Imposition index 2
                                     Platform flags 0x41
                                     Capability flags 0x0
                                     Port channel group id 0x0
                                     New link id 0
                                   Adjacency pointer 0x4781B2A0
Protocol Interface                 Address
                                   Next-hop unknown
7600-PE1#

Outputs for check the LSP and Routing:
===========================
7600-PE1#sh ip route 10.4.0.1
Routing entry for 10.4.0.1/32
  Known via "isis", distance 80, metric 40, type level-2
  Redistributing via isis
  Last update from 10.4.0.1 on Tunnel1002, 3d11h ago
  Routing Descriptor Blocks:
  * 10.4.0.1, from 10.4.0.1, 3d11h ago, via Tunnel1002
      Route metric is 40, traffic share count is 1
7600-PE1#

7600-PE1#sh mpls for 10.4.0.1 det
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop    
Label      Label      or Tunnel Id     Switched      interface              
17         Pop Label  10.4.0.1/32      0             Tu1002     point2point 
        MAC/Encaps=14/18, MRU=4470, Label Stack{226}, via Gi1/3
        002333693DC06400F174D3408847 000E2000
        No output feature configured
7600-PE1#
7600-PE1#sh mpls traffic-eng tunnels tu1002

Name: 7600-PE1_t1002                      (Tunnel1002) Destination: 10.4.0.1
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 30)

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 4  4   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute announce: enabled  LockDown: disabled Loadshare: 0 [0] bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled


  InLabel  :  -
  OutLabel : GigabitEthernet1/3, 226
  Next Hop : 13.13.13.2
  FRR OutLabel : Tunnel5003, explicit-null 
  RSVP Signalling Info:
       Src 10.1.0.1, Dst 10.4.0.1, Tun_Id 1002, Tun_Instance 1118
    RSVP Path Info:
      My Address: 13.13.13.1   
      Explicit Route: 13.13.13.2 42.42.42.2 10.4.0.1 
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:  10.2.0.1(226) 10.4.0.1(0)
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 30 (TE)
    Explicit Route: 12.12.12.2 34.34.34.2 10.4.0.1 
  History:
    Tunnel:
      Time since created: 6 days, 22 hours, 19 minutes
      Time since path change: 3 days, 11 hours, 38 minutes
      Number of LSP IDs (Tun_Instances) used: 334
    Current LSP: [ID: 1118]
      Uptime: 3 days, 11 hours, 38 minutes
      Selection: reoptimization
    Prior LSP: [ID: 952]
      ID: path option 10 [952]
      Removal Trigger: re-route path error
      Last Error: RSVP:: Path Error from 10.1.0.1: Notify: Tunnel locally repaired (flags 0)
7600-PE1#

7600-PE1#rem login swi
7600-PE1#rem login switch 
Trying Switch ...
Entering CONSOLE for Switch
Type "^C^C^C" to end this session


7600-PE1-sp#
7600-PE1-sp#
7600-PE1-sp#sh mpls for 10.4.0.1
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop    
Label      Label      or Tunnel Id     Switched      interface              
17    [T]  Pop Label  10.4.0.1/32      0             Tu1002     point2point 

[T]     Forwarding through a LSP tunnel.
        View additional labelling info with the 'detail' option
7600-PE1-sp#sh mpls for 10.4.0.1 det
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop    
Label      Label      or Tunnel Id     Switched      interface              
17         Pop Label  10.4.0.1/32      0             Tu1002     point2point 
        MAC/Encaps=14/18, MRU=4470, Label Stack{226}, via Gi1/3
        002333693DC06400F174D3408847 000E2000
        No output feature configured

7600-PE1-sp#sh mls cef mpls labels 17 det
Codes: M - mask entry, V - value entry, A - adjacency index, P - FIB Priority
       D - FIB Don't short-cut, m - mod-num, E - ELSP?
Format: MPLS - (b | xtag vpn pi cr mcast label1 exp1 eos1 valid2 label2 exp2 eos2)
V(2183   ): B | 1 0    0 0 0 17      0 1 0 0       0 0 (A:262144 ,P:0,D:0,m:0 :E:1)
M(2183   ): F | 1 FFF  0 0 1 FFFFF   0 1 0 0       0 0
V(2184   ): B | 1 0    0 0 0 17      0 0 0 0       0 0 (A:278528 ,P:0,D:0,m:0 :E:1)
M(2184   ): F | 1 FFF  0 0 1 FFFFF   0 1 0 0       0 0
7600-PE1-sp#sh mls cef adj entry 262144 det
Index: 262144  smac: 0000.0000.0000, dmac: 6400.f174.d340
               mtu: 65535, vlan: 1014, dindex: 0x7FFA, l3rw_vld: 1
               format: MPLS, flags: 0x8610 
               label0: 0, exp: 0, ovr: 0
               label1: 0, exp: 0, ovr: 0
               label2: 526336, exp: 0, ovr: 0
               op: REPLACE_LABEL2
               packets: 0, bytes: 0

7600-PE1-sp#sh mls cef adj entry 278528 det
Index: 278528  smac: 0000.0000.0000, dmac: 6400.f174.d340
               mtu: 65535, vlan: 1014, dindex: 0x7FFA, l3rw_vld: 1
               format: MPLS, flags: 0x8610 
               label0: 0, exp: 0, ovr: 0
               label1: 0, exp: 0, ovr: 0
               label2: 526344, exp: 0, ovr: 0
               op: REPLACE_LABEL2
               packets: 0, bytes: 0

7600-PE1-sp#

7600-PE1#sh vlan internal usage | in 1014
1014 vrf_0_vlan
7600-PE1#


Similarly we can check the outputs and verify the hardware programming and routing on other nodes.

If you see the first section of the above outputs, you will notice that there are primary as well as back Tunnels which have got automatically created. If we try to see the config of any of those tunnels, we wont be able to see anything as the whole configuration is in-memory. In the second section, we are trying to verify the routing as well as the hardware programming.  Since, in our topology, we are not using any DFC cards, we cannot check any information on the linecards as the lookups are done on the SP for the CFC cards. If there would have been a DFC, we would have to check the same information on the DFC cards as well. Another important point to remember is that we need to check the adjacency of the TE tunnels. Sometimes, if there is any missing / wrong information in the Adjacency of the tunnels, it could cause forwarding issue. But the initial level of troubleshooting could be started by the ping mpls traffic-eng test.

Output from 7600-PE1:
================
7600-PE1#ping mpls traffic-eng tunnel 1002
Sending 5, 100-byte MPLS Echos to Tunnel1002, 
     timeout is 2 seconds, send interval is 0 msec:

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
  'L' - labeled output interface, 'B' - unlabeled output interface, 
  'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
  'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry, 
  'P' - no rx intf label prot, 'p' - premature termination of LSP, 
  'R' - transit router, 'I' - unknown upstream index,
  'l' - Label switched with FEC change, 'd' - see DDMAP for return code,
  'X' - unknown return code, 'x' - return code 0

Type escape sequence to abort.
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
7600-PE1#

Lets now have a look at some more outputs:

Output on 7600-PE1:
===============
7600-PE1#show adjacency tunnel1002 det
Protocol Interface                 Address
IP       Tunnel1002                point2point(8)
                                   0 packets, 0 bytes
                                   epoch 0
                                   sourced in sev-epoch 0
                                   empty encap string
                                   P2P-ADJ
                                   Next chain element:
                                    label 226
                                   FRR Primary
                                   <primary:  TAG adj out of GigabitEthernet1/3, addr 13.13.13.2>
TAG      Tunnel1002                point2point(4)
                                   0 packets, 0 bytes
                                   epoch 0
                                   sourced in sev-epoch 0
                                   empty encap string
                                   P2P-ADJ
                                   Next chain element:
                                    label 226
                                   FRR Primary
                                   <primary:  TAG adj out of GigabitEthernet1/3, addr 13.13.13.2>
7600-PE1#
7600-PE1#show adjacency tunnel1002 internal
Protocol Interface                 Address
IP       Tunnel1002                point2point(8)
                                   0 packets, 0 bytes
                                   epoch 0
                                   sourced in sev-epoch 0
                                   empty encap string
                                   P2P-ADJ
                                   Next chain element:
                                    label 226
                                   FRR Primary
                                   <primary:  TAG adj out of GigabitEthernet1/3, addr 13.13.13.2>
                                    parent oce 0x502801B0
                                   L3 mtu 4466
                                   Flags (0x128C6)
                                   Fixup disabled
                                   HWIDB/IDB pointers 0x501030CC/0x565AC5B8
                                   IP redirect disabled
                                   Switching vector: IPv4 midchain adj oce
                                   Output features: HW Shortcut Installation
                                   Next-hop inferred from 1 reference
                                   MPLS subblock: flags 0x4 
                                      GigabitEthernet1/3 13.13.13.2 label 226
Protocol Interface                 Address
                                      FRR protected by Tunnel5003 label implicit-null
                                      chain pointer 0x502801B0:  label 226
                                     FRR Primary
                                     <primary:  TAG adj out of GigabitEthernet1/3, addr 13.13.13.2>
                                      adj-sb send-slotmask: 0x0 
                                   Adjacency pointer 0x4781ADC0
                                   Next-hop 10.4.0.1
TAG      Tunnel1002                point2point(4)
                                   0 packets, 0 bytes
                                   epoch 0
                                   sourced in sev-epoch 0
                                   empty encap string
                                   P2P-ADJ
                                   Next chain element:
                                    label 226
                                   FRR Primary
                                   <primary:  TAG adj out of GigabitEthernet1/3, addr 13.13.13.2>
                                    parent oce 0x5027FED8
                                   L3 mtu 4466
                                   Flags (0x128C6)
                                   Fixup disabled
Protocol Interface                 Address
                                   HWIDB/IDB pointers 0x501030CC/0x565AC5B8
                                   IP redirect disabled
                                   Switching vector: MPLS midchain adjacency oce
                                   Next-hop cannot be inferred
                                   MPLS subblock: flags 0x4 
                                      GigabitEthernet1/3 13.13.13.2 label 226
                                      FRR protected by Tunnel5003 label implicit-null
                                      chain pointer 0x5027FED8:  label 226
                                     FRR Primary
                                     <primary:  TAG adj out of GigabitEthernet1/3, addr 13.13.13.2>
                                      adj-sb send-slotmask: 0x0 

                                   Adjacency platform space:
                                     TE Imposition index 4
                                     Platform flags 0x41
                                     Capability flags 0x0
                                     Port channel group id 0x0
                                     New link id 0
                                   Adjacency pointer 0x4781AC20
                                   Next-hop unknown
7600-PE1#

In the above outputs, we can see that the adjacency is pointing to the same information which have in the show mpls traffic-eng output. Also, we see that the backup FRR tunnel is Tunnel 5003. We can check the MFI (MPLS Forwarding Infrastructure) adjacency information using the command : show mpls infrastructure lfd adj-sb internal

Output from 7600-PE1
================
7600-PE1-sp#sh mpls infrastructure lfd adj-sb internal 
 MPLS Adj sb 0x5916479C       Parent Adj  0x4509D6A0
    MPLS subblock: flags 0x4 
       GigabitEthernet1/1 12.12.12.2 label implicit-null
       FRR protected by Tunnel5000 label implicit-null
       chain pointer 0x5914D0D0:  label implicit-null
      FRR Primary
      <primary:  IP adj out of GigabitEthernet1/1, addr 12.12.12.2>
       adj-sb send-slotmask: 0x0 
 MPLS Adj sb 0x591646D4       Parent Adj  0x4509D500
    MPLS subblock: flags 0x4 
       GigabitEthernet1/1 12.12.12.2 label implicit-null
       FRR protected by Tunnel5000 label implicit-null
       chain pointer 0x5914D4C0:  label implicit-null
      FRR Primary
      <primary:  TAG adj out of GigabitEthernet1/1, addr 12.12.12.2>
       adj-sb send-slotmask: 0x0 
 MPLS Adj sb 0x5916415C       Parent Adj  0x5916E8C0
    MPLS subblock: flags 0x0 
       GigabitEthernet1/3 13.13.13.2 label 22
       chain pointer 0x5916C3D8:  label 22 TAG adj out of GigabitEthernet1/3, addr 13.13.13.2
       adj-sb send-slotmask: 0x0 
 MPLS Adj sb 0x59164094       Parent Adj  0x5916E720
    MPLS subblock: flags 0x0 
       GigabitEthernet1/3 13.13.13.2 label 22
       chain pointer 0x5916C368:  label 22 TAG adj out of GigabitEthernet1/3, addr 13.13.13.2
       adj-sb send-slotmask: 0x0 
 MPLS Adj sb 0x5916460C       Parent Adj  0x4509D360
    MPLS subblock: flags 0x4 
       GigabitEthernet1/3 13.13.13.2 label implicit-null
       FRR protected by Tunnel5002 label implicit-null
       chain pointer 0x5914D370:  label implicit-null
      FRR Primary
      <primary:  IP adj out of GigabitEthernet1/3, addr 13.13.13.2>
       adj-sb send-slotmask: 0x0 
 MPLS Adj sb 0x59164544       Parent Adj  0x4509D1C0
    MPLS subblock: flags 0x4 
       GigabitEthernet1/3 13.13.13.2 label implicit-null
       FRR protected by Tunnel5002 label implicit-null
       chain pointer 0x5914CB20:  label implicit-null
      FRR Primary
      <primary:  TAG adj out of GigabitEthernet1/3, addr 13.13.13.2>
       adj-sb send-slotmask: 0x0 
 MPLS Adj sb 0x5916447C       Parent Adj  0x4509D020
    MPLS subblock: flags 0x4 
       GigabitEthernet1/3 13.13.13.2 label 226

The same information can also be checked on the DFC to verify the programming on the DFC cards as well.

Hope the above information was helpful and hope you enjoyed reading it.

Reach out to me for any questions on the same.

Cheers...!!!

Comments (1) -

  • Genie

    1/22/2014 9:13:13 PM |

    Recently, I was doing some testing and found that if there are two RSP/SUP cards on a 7600 platform and if the redundancy mode is configured as SSO or RPR+, the Automesh tunnels will not come up.
    In order to make the Autotunnel mesh come up, you will have to configure the redundancy mode as rpr. Below is the CCO document for the same.

    www.cisco.com/.../...figuration_Guide_Chapter.html

Comments are closed