Genie's Tech Blog

Where knowledge has no dimensions

Inter-Area MPLS TE on IOS-XR

Hello Everyone,

As mentioned earlier, today I will be discussing about Inter-Area MPLS TE. In my previous blog, we already discussed regarding Inter-Domain MPLS traffic engineering and we further discussed on the Inter-AS MPLS traffic engineering. We are now going to the second form of Inter-Domain MPLS traffic engineering i.e. Inter-Area MPLS traffic engineering. Inter-Area MPLS TE is fairly simple as compared to Inter-AS MPLS TE. Also, I will be discussing this topic on IOS-XR platform.

The MPLS TE Interarea Tunnels feature allows you to establish MPLS TE tunnels that span multiple Interior Gateway Protocol (IGP) areas and levels, removing the restriction that had required the tunnel head-end and tail-end routers both be in the same area. The IGP can be either Intermediate System-to-Intermediate System (IS-IS) or Open Shortest Path First (OSPF). The ABR routers will maintain two topology databases. In case of ospf, one for Area 0 and one for non-backbone Area. In case of IS-IS, one for Level-1 and one for Level-2. It is possible to configure multiple Area within Level-1 ISIS. This is transparent to TE and TE will only have topology information of the ISIS Level and TE is not aware of the ISIS Area ID. Inter-area MPLS TE adds an ability to configure an inter-area TE LSP by specifying a loose source route of ABRs along the path. It will be the responsibility of the ABR, having a complete view of both areas, to find a path obeying the TE LSP constraints within the next area to reach the “next hop” ABR (as specified on the head-end). The same operation will be performed by the last ABR connected to the tail-end area to reach the tail-end LSR. From the route computation viewpoint, the head-end automatically computes a route to the first ABR (that will of course obey the constraints of the TE LSP). Then the route is expanded at the first ABR till the second ABR, until the last ABR that will compute the route to reach the tail-end LSR that resides in the tail-end area. If no path can be found by PCALC to reach the next ABR along the path, then a Path Error message is sent to the head-end. Note that user needs to specify the router ID of the ABR node (as opposed to a link address on the ABR). The user is able to specify the strict hops beyond the first loose hop. The router doing the ERO expansion will not remove the strict hops beyond the next loose hop. Note that it is up to the user to specify the reachable explicit path for the inter-area tunnel. Head-end does not perform any route look up to check the reach-ability of the ABRs. If next loose hop is not reachable, a path error is sent back from the ABR to the head-end and tunnel remains in down state. The inter-area LSPs are signaled using loose hop Sub-objects in their Explicit Route Objects (EROs). In multi-area TE, a TE LSP can be established in each area independently but not spanning more than one area. 

Inter-area MPLS TE adds an ability to configure an inter-area TE LSP by specifying a loose source route of ABRs along the path. It will be the responsibility of the ABR, having a complete view of both areas, to find a path obeying the TE LSP constraints within the next area to reach the “next hop” ABR (as specified on the head-end). The same operation will be performed by the last ABR connected to the tail-end area to reach the tail-end LSR. The head-end automatically computes a route to the first ABR (that will of course obey the constraints of the TE LSP). Then the route is expanded at the first ABR till the second ABR, until the last ABR that will compute the route to reach the tail-end LSR that resides in the tail-end area. If no path can be found by PCALC to reach the next ABR along the path, then a Path Error message is sent to the head-end. Note that it is up to the user to specify the reachable explicit path for the inter-area tunnel. Head-end does not perform any route look up to check the reach-ability of the ABRs. If next loose hop is not reachable, a path error is sent back from the ABR to the head-end and tunnel remains in down state. Also, note that user needs to specify the router ID of the ABR node (as opposed to a link address on the ABR).  The user is able to specify the strict hops beyond the first loose hop.

Let us now have a look at an example and outputs showing the Inter-Area MPLS TE scenario. Let us consider the below mentioned topology:

 

In the above topology Area 1 has been configured between R1 and R3, Area 0 has been configured between R3 and R4 and Area 2 has been configured between R4 and R6. R1 is acting as the headend of the TE tunnel. Below are the configs for all the routers.

Config on XR1: 
==============
hostname XR1
explicit-path name lanos
 index 1 next-address loose ipv4 unicast 3.3.3.3
 index 2 next-address loose ipv4 unicast 4.4.4.4
 index 3 next-address loose ipv4 unicast 6.6.6.6
!
interface Loopback0
 ipv4 address 1.1.1.1 255.255.255.255
!
interface tunnel-te100
 ipv4 unnumbered Loopback0
 autoroute announce
 destination 6.6.6.6
 path-option 1 explicit name lanos
!
interface GigabitEthernet0/0/0/0
 ipv4 address 13.13.13.1 255.255.255.252
!
interface GigabitEthernet0/0/0/1
 shutdown
!
interface GigabitEthernet0/0/0/2
 shutdown
!
interface GigabitEthernet0/0/0/3
 shutdown
!
interface GigabitEthernet0/0/0/4
 shutdown
!
router ospf 100
 router-id 1.1.1.1
 area 1
  mpls traffic-eng
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
 !
 mpls traffic-eng router-id Loopback0
!
rsvp
 interface GigabitEthernet0/0/0/0
 !
!
mpls traffic-eng
 interface GigabitEthernet0/0/0/0
 !
!
mpls ldp
 router-id 1.1.1.1
 interface GigabitEthernet0/0/0/0
 !
!
end

Config on XR3:
==============
hostname XR3
logging console debugging
interface Loopback0
 ipv4 address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 13.13.13.2 255.255.255.252
!
interface GigabitEthernet0/0/0/1
 shutdown
!
interface GigabitEthernet0/0/0/2
 ipv4 address 34.34.34.1 255.255.255.252
!
interface GigabitEthernet0/0/0/3
 shutdown
!
interface GigabitEthernet0/0/0/4
 shutdown
!
router ospf 100
 router-id 3.3.3.3
 area 0
  mpls traffic-eng
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/2
  !
 !
 area 1
  mpls traffic-eng
  interface GigabitEthernet0/0/0/0
  !
 !
 mpls traffic-eng router-id Loopback0
!
rsvp
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/2
 !
!
mpls traffic-eng
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/2
 !
!
mpls ldp
 router-id 3.3.3.3
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/2
 !
!
end

Config on XR4:
==============
hostname XR4
interface Loopback0
 ipv4 address 4.4.4.4 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 46.46.46.1 255.255.255.252
!
interface GigabitEthernet0/0/0/1
 shutdown
!
interface GigabitEthernet0/0/0/2
 ipv4 address 34.34.34.2 255.255.255.252
!
interface GigabitEthernet0/0/0/3
 shutdown
!
interface GigabitEthernet0/0/0/4
 shutdown
!
router ospf 100
 router-id 4.4.4.4
 area 0
  mpls traffic-eng
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/2
  !
 !
 area 2
  mpls traffic-eng
  interface GigabitEthernet0/0/0/0
  !
 !
 mpls traffic-eng router-id Loopback0
!
rsvp
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/2
 !
!
mpls traffic-eng
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/2
 !
!
mpls ldp
 router-id 4.4.4.4
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/2
 !
!
end

Config on XR6:
==============
hostname XR6
interface Loopback0
 ipv4 address 6.6.6.6 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 46.46.46.2 255.255.255.252
!
interface GigabitEthernet0/0/0/1
 shutdown
!
interface GigabitEthernet0/0/0/2
 shutdown
!
interface GigabitEthernet0/0/0/3
 shutdown
!
interface GigabitEthernet0/0/0/4
 shutdown
!
router ospf 100
 router-id 6.6.6.6
 area 2
  mpls traffic-eng
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
 !
 mpls traffic-eng router-id Loopback0
!
rsvp
 interface GigabitEthernet0/0/0/0
 !
!
mpls traffic-eng
 interface GigabitEthernet0/0/0/0
 !
!
mpls ldp
 router-id 6.6.6.6
 interface GigabitEthernet0/0/0/0
 !
!
end

If you see the above config, we will see that since R3 and R4 are the ABR routers, they have been configured with mpls traffic-eng under both Area 1 and Area 0 on R3 and under Area 0 and Area 2 on R4. With this configuration in our Inter-Area MPLS TE comes up on R1. Lets have a look at the output below:

Output on R1:
==========
RP/0/0/CPU0:XR1#sh mpls traffic-eng tunnels 100
Fri Nov 30 13:58:59.351 IST


Name: tunnel-te100  Destination: 6.6.6.6 
  Status:
    Admin:    up Oper:   up   Path:  valid   Signalling: connected

    path option 1,  type explicit lanos (Basis for Setup, path weight 1)
    G-PID: 0x0800 (derived from egress interface properties)
    Bandwidth Requested: 0 kbps  CT0
    Creation Time: Thu Nov 29 01:19:43 2012 (1d12h ago)
  Config Parameters:
    Bandwidth:        0 kbps (CT0) Priority:  7  7 Affinity: 0x0/0xffff
    Metric Type: TE (default)
    Hop-limit: disabled
    AutoRoute:  enabled  LockDown: disabled   Policy class: not set
    Forwarding-Adjacency: disabled
    Loadshare:          0 equal loadshares
    Auto-bw: disabled
    Fast Reroute: Disabled, Protection Desired: None
    Path Protection: Not Enabled
    Soft Preemption: Disabled
  History:
    Tunnel has been up for: 1d12h (since Thu Nov 29 01:20:41 IST 2012)
    Current LSP:
      Uptime: 1d12h (since Thu Nov 29 01:20:41 IST 2012)
    Reopt. LSP:
      Last Failure:
        LSP not signalled, identical to the [CURRENT] LSP
        Date/Time: Fri Nov 30 13:19:43 IST 2012 [00:39:16 ago]

  Path info (OSPF 100 area 1):
  Node hop count: 1
  Hop0: 13.13.13.2
  Hop1: 3.3.3.3
  Hop2: 4.4.4.4
  Hop3: 6.6.6.6
Displayed 1 (of 1) heads, 0 (of 0) midpoints, 0 (of 0) tails
Displayed 1 up, 0 down, 0 recovering, 0 recovered heads
RP/0/0/CPU0:XR1#

In the above output we see 4 hops - Hop0, Hop1, Hop2 and Hop3. We can have a more better understanding on the output with the detail keyword after the above command. Lets now have a look at the same:

Output on R1:
==========
RP/0/0/CPU0:XR1#sh mpls traffic-eng tunnels 100 detail 
Fri Nov 30 14:00:05.424 IST


Name: tunnel-te100  Destination: 6.6.6.6 
  Status:
    Admin:    up Oper:   up   Path:  valid   Signalling: connected

    path option 1,  type explicit lanos (Basis for Setup, path weight 1)
    G-PID: 0x0800 (derived from egress interface properties)
    Bandwidth Requested: 0 kbps  CT0
    Creation Time: Thu Nov 29 01:19:43 2012 (1d12h ago)
  Config Parameters:
    Bandwidth:        0 kbps (CT0) Priority:  7  7 Affinity: 0x0/0xffff
    Metric Type: TE (default)
    Hop-limit: disabled
    AutoRoute:  enabled  LockDown: disabled   Policy class: not set
    Forwarding-Adjacency: disabled
    Loadshare:          0 equal loadshares
    Auto-bw: disabled
    Fast Reroute: Disabled, Protection Desired: None
    Path Protection: Not Enabled
    Soft Preemption: Disabled
  Reoptimization Info in Inter-area:
    Better Path Queries sent = 36; Preferred Path Exists received = 0
    Last Better Path Query was sent 00:40:22 ago
    Preferred Path Exists was not received

  SNMP Index: 9
  History:
    Tunnel has been up for: 1d12h (since Thu Nov 29 01:20:41 IST 2012)
    Current LSP:
      Uptime: 1d12h (since Thu Nov 29 01:20:41 IST 2012)
    Reopt. LSP:
      Last Failure:
        LSP not signalled, identical to the [CURRENT] LSP
        Date/Time: Fri Nov 30 13:19:43 IST 2012 [00:40:22 ago]
  Current LSP Info: 
    Instance: 2, Signaling Area: OSPF 100 area 1
    Uptime: 1d12h (since Thu Nov 29 01:20:41 IST 2012)
    Outgoing Interface: GigabitEthernet0/0/0/0, Outgoing Label: 16004
    Router-IDs: local      1.1.1.1
                downstream 3.3.3.3
    Soft Preemption: None
    Path Info:
      Outgoing:
        Explicit Route:
          Strict, 13.13.13.2
          Strict, 3.3.3.3
          Loose, 4.4.4.4
          Loose, 6.6.6.6

      Record Route: Disabled
      Tspec: avg rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
      Session Attributes: Local Prot: Not Set, Node Prot: Not Set, BW Prot: Not Set
                          Soft Preemption Desired: Not Set
    Resv Info: None
      Record Route: Disabled
      Fspec: avg rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Displayed 1 (of 1) heads, 0 (of 0) midpoints, 0 (of 0) tails
Displayed 1 up, 0 down, 0 recovering, 0 recovered heads
RP/0/0/CPU0:XR1#

Now in the detailed output, we see that this MPLS TE is configured for Inter-Area. Also, the next downstream router-id is 3.3.3.3. Till 3.3.3.3 all the hops are strict hops, 4.4.4.4 and 6.6.6.6 are Loose hops for this MPLS TE tunnel.  As described above, both the ABR routers will have two MPLS traffic-engineering topology databases:

Output on R3:
==========
RP/0/0/CPU0:XR3#sh mpls tra topology summary 
Fri Nov 30 13:56:05.986 IST
My_System_id: 3.3.3.3 (OSPF 100 area 0)
My_System_id: 3.3.3.3 (OSPF 100 area 1)
My_BC_Model_Type: RDM 

Signalling error holddown: 10 sec Global Link Generation 18486

OSPF 100  area 0
  Local System Id:          3.3.3.3
  TE router ID configured:  3.3.3.3
               in use:      3.3.3.3

    IGP Id: 3.3.3.3, MPLS TE Id: 3.3.3.3 Router Node 
        1 links

    IGP Id: 4.4.4.4, MPLS TE Id: 4.4.4.4 Router Node 
        1 links

    IGP Id: 34.34.34.2, Network Node 
        2 links

    Total: 3 nodes (2 router, 1 network), 4 links
OSPF 100  area 1
  Local System Id:          3.3.3.3
  TE router ID configured:  3.3.3.3
               in use:      3.3.3.3

    IGP Id: 1.1.1.1, MPLS TE Id: 1.1.1.1 Router Node 
        1 links

    IGP Id: 3.3.3.3, MPLS TE Id: 3.3.3.3 Router Node 
        1 links

    IGP Id: 13.13.13.2, Network Node 
        2 links

    Total: 3 nodes (2 router, 1 network), 4 links

Grand Total: 6 nodes (4 router, 2 network)  8 links
RP/0/0/CPU0:XR3#

Output on R4:
==========
RP/0/0/CPU0:XR4#sh mpls traffic-eng topology summary 
Fri Nov 30 13:56:25.317 IST
My_System_id: 4.4.4.4 (OSPF 100 area 0)
My_System_id: 4.4.4.4 (OSPF 100 area 2)
My_BC_Model_Type: RDM 

Signalling error holddown: 10 sec Global Link Generation 18478

OSPF 100  area 0
  Local System Id:          4.4.4.4
  TE router ID configured:  4.4.4.4
               in use:      4.4.4.4

    IGP Id: 3.3.3.3, MPLS TE Id: 3.3.3.3 Router Node 
        1 links

    IGP Id: 4.4.4.4, MPLS TE Id: 4.4.4.4 Router Node 
        1 links

    IGP Id: 34.34.34.2, Network Node 
        2 links

    Total: 3 nodes (2 router, 1 network), 4 links
OSPF 100  area 2
  Local System Id:          4.4.4.4
  TE router ID configured:  4.4.4.4
               in use:      4.4.4.4

    IGP Id: 4.4.4.4, MPLS TE Id: 4.4.4.4 Router Node 
        1 links

    IGP Id: 6.6.6.6, MPLS TE Id: 6.6.6.6 Router Node 
        1 links

    IGP Id: 46.46.46.2, Network Node 
        2 links

    Total: 3 nodes (2 router, 1 network), 4 links

Grand Total: 6 nodes (4 router, 2 network)  8 links
RP/0/0/CPU0:XR4#

Similarly will be the case of ISIS. One database will be for Level-1 and the other for Level-2. We can also see the OSPF database for the Opaque LSA's for the traffic-engineering tunnel. Lets have a look at the same:

RP/0/0/CPU0:XR1#sh ospf database 
Sun Dec  2 21:34:41.681 IST


            OSPF Router with ID (1.1.1.1) (Process ID 100)

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         773         0x800000a7 0x00f627 2
3.3.3.3         3.3.3.3         432         0x800000a7 0x00fb25 1

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
13.13.13.2      3.3.3.3         432         0x800000a6 0x00b69b

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
3.3.3.3         3.3.3.3         432         0x800000a6 0x00631b
4.4.4.4         3.3.3.3         432         0x800000a6 0x003f3a
6.6.6.6         3.3.3.3         432         0x800000a6 0x00ec83
34.34.34.0      3.3.3.3         432         0x800000a6 0x000f18
46.46.46.0      3.3.3.3         432         0x800000a6 0x00679a

                Type-10 Opaque Link Area Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Opaque ID
1.0.0.0         1.1.1.1         773         0x800000a6 0x000d77        0
1.0.0.0         3.3.3.3         432         0x800000a6 0x00155f        0
1.0.0.4         1.1.1.1         773         0x800000a6 0x00eaca        4
1.0.0.4         3.3.3.3         432         0x800000a6 0x00ccdf        4
RP/0/0/CPU0:XR1#

RP/0/0/CPU0:XR1#sh ospf database opaque-area 1.0.0.4 
Sun Dec  2 21:35:18.103 IST


            OSPF Router with ID (1.1.1.1) (Process ID 100)

                Type-10 Opaque Link Area Link States (Area 1)

  LS age: 810
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.4
  Opaque Type: 1
  Opaque ID: 4
  Advertising Router: 1.1.1.1
  LS Seq Number: 800000a6
  Checksum: 0xeaca
  Length: 124

    Link connected to Broadcast network
      Link ID : 13.13.13.2
      (all bandwidths in bytes/sec)
      Interface Address : 13.13.13.1
      Admin Metric : 1
      Maximum bandwidth : 125000000
      Maximum reservable bandwidth global: 0
      Number of Priority : 8
      Priority 0 :                    0  Priority 1 :                    0
      Priority 2 :                    0  Priority 3 :                    0
      Priority 4 :                    0  Priority 5 :                    0
      Priority 6 :                    0  Priority 7 :                    0
      Affinity Bit : 0
      IGP Metric : 1

    Number of Links : 1

  LS age: 469
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.4
  Opaque Type: 1
  Opaque ID: 4
  Advertising Router: 3.3.3.3
  LS Seq Number: 800000a6
  Checksum: 0xccdf
  Length: 124

    Link connected to Broadcast network
      Link ID : 13.13.13.2
      (all bandwidths in bytes/sec)
      Interface Address : 13.13.13.2
      Admin Metric : 1
      Maximum bandwidth : 125000000
      Maximum reservable bandwidth global: 0
      Number of Priority : 8
      Priority 0 :                    0  Priority 1 :                    0
      Priority 2 :                    0  Priority 3 :                    0
      Priority 4 :                    0  Priority 5 :                    0
      Priority 6 :                    0  Priority 7 :                    0
      Affinity Bit : 0
      IGP Metric : 1

    Number of Links : 1

RP/0/0/CPU0:XR1#

RP/0/0/CPU0:XR1#sh ospf database opaque-area 
Sun Dec  2 21:33:33.541 IST


            OSPF Router with ID (1.1.1.1) (Process ID 100)

                Type-10 Opaque Link Area Link States (Area 1)

  LS age: 705
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 1.1.1.1
  LS Seq Number: 800000a6
  Checksum: 0xd77
  Length: 28

    MPLS TE router ID : 1.1.1.1

    Number of Links : 0

  LS age: 364
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 3.3.3.3
  LS Seq Number: 800000a6
  Checksum: 0x155f
  Length: 28

    MPLS TE router ID : 3.3.3.3

    Number of Links : 0

  LS age: 705
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.4
  Opaque Type: 1
  Opaque ID: 4
  Advertising Router: 1.1.1.1
  LS Seq Number: 800000a6
  Checksum: 0xeaca
  Length: 124

    Link connected to Broadcast network
      Link ID : 13.13.13.2
      (all bandwidths in bytes/sec)
      Interface Address : 13.13.13.1
      Admin Metric : 1
      Maximum bandwidth : 125000000
      Maximum reservable bandwidth global: 0
      Number of Priority : 8
      Priority 0 :                    0  Priority 1 :                    0
      Priority 2 :                    0  Priority 3 :                    0
      Priority 4 :                    0  Priority 5 :                    0
      Priority 6 :                    0  Priority 7 :                    0
      Affinity Bit : 0
      IGP Metric : 1

    Number of Links : 1

  LS age: 364
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.4
  Opaque Type: 1
  Opaque ID: 4
  Advertising Router: 3.3.3.3
  LS Seq Number: 800000a6
  Checksum: 0xccdf
  Length: 124

    Link connected to Broadcast network
      Link ID : 13.13.13.2
      (all bandwidths in bytes/sec)
      Interface Address : 13.13.13.2
      Admin Metric : 1
      Maximum bandwidth : 125000000
      Maximum reservable bandwidth global: 0
      Number of Priority : 8
      Priority 0 :                    0  Priority 1 :                    0
      Priority 2 :                    0  Priority 3 :                    0
      Priority 4 :                    0  Priority 5 :                    0
      Priority 6 :                    0  Priority 7 :                    0
      Affinity Bit : 0
      IGP Metric : 1

    Number of Links : 1

So from the above output we can see that there has been 4 Link IDs been generated for the 2 routers and other details of the router related to OSPF. If we go into the detail of the rsvp signalling for the Inter-Area TE tunnel, we can see the following command output:

RP/0/0/CPU0:XR1#sh rsvp session detail 
Sun Dec  2 21:46:49.668 IST
SESSION: IPv4-LSP Addr: 6.6.6.6, TunID: 100, ExtID: 1.1.1.1
 PSBs: 1, RSBs: 1, Requests: 0
 LSPId: 150
 Tunnel Name: XR1_t100
  RSVP Path Info:
   InLabel: No intf, No label
   Incoming Address: Unknown
   Explicit Route:
     Strict, 13.13.13.2/32
     Strict, 3.3.3.3/32
     Loose, 4.4.4.4/32
     Loose, 6.6.6.6/32
   Record Route: None
   Tspec: avg rate=0, burst=1K, peak rate=0
  RSVP Resv Info:
   OutLabel: GigabitEthernet0/0/0/0, 16004
   FRR OutLabel: No intf, No label
   Record Route: None
   Fspec: avg rate=0, burst=1K, peak rate=0

RP/0/0/CPU0:XR1#

We can see here which are the loose and the strict hops. I am also attaching the debug rsvp message output in the file when the tunnel comes up so that you can check the rsvp message flow. Hope the above post has been useful. Please feel free to reach out to me in case of any queries on Inter-Area MPLS TE.

inter-area_rsvp_debug.txt (52.39 kb)

 

 

Comments are closed